Tickets Known bugs for Beta3

Peter

Member
I have found a few bugs, but instead of opening up a different thread every time, I will just post them here.

1. Ticket prefix does not update automatically.
- When a staff member replies to a ticket, the prefix should change to "Pending user reply". It does not. Likewise, when the user replies to the ticket, it should change to "Pending staff reply". Again, this does not happen.

2. When a ticket is deleted, an error occurs with the name "nfTickets_requested_ticket_not_found".

Code:
#0 src/XF/Mvc/Entity/Entity.php(101): XF\Mvc\Entity\Entity->get('event_id')
#1 src/addons/NF/Tickets/Entity/Ticket.php(877): XF\Mvc\Entity\Entity->__get('event_id')
#2 src/XF/Mvc/Entity/Entity.php(1580): NF\Tickets\Entity\Ticket->_postDelete()
#3 src/addons/NF/Tickets/Service/Ticket/Deleter.php(70): XF\Mvc\Entity\Entity->delete()
#4 src/addons/NF/Tickets/Pub/Controller/Ticket.php(770): NF\Tickets\Service\Ticket\Deleter->delete('hard', '')
#5 src/XF/Mvc/Dispatcher.php(321): NF\Tickets\Pub\Controller\Ticket->actionDelete(Object(XF\Mvc\ParameterBag))
#6 src/XF/Mvc/Dispatcher.php(248): XF\Mvc\Dispatcher->dispatchClass('NF\\Tickets:Tick...', 'Delete', Object(XF\Mvc\RouteMatch), Object(NF\Tickets\Pub\Controller\Ticket), NULL)
#7 src/XF/Mvc/Dispatcher.php(100): XF\Mvc\Dispatcher->dispatchFromMatch(Object(XF\Mvc\RouteMatch), Object(NF\Tickets\Pub\Controller\Ticket), NULL)
#8 src/XF/Mvc/Dispatcher.php(50): XF\Mvc\Dispatcher->dispatchLoop(Object(XF\Mvc\RouteMatch))
#9 src/XF/App.php(2177): XF\Mvc\Dispatcher->run()
#10 src/XF.php(390): XF\App->run()
#11 index.php(20): XF::runApp('XF\\Pub\\App')
#12 {main}

3. When a guest creates a ticket, an e-mail is sent stating the ticket has been submitted. However, upon reply to that ticket by a staff member, no other e-mail is sent to the guest stating that the ticket has been replied to. It also wants the guest (when replying to the ticket) to fill out their name and e-mail again. This is a pointless extra step.

4. Guests can't use the same name a user. If a guest with the name "Peter" submits a ticket, and there is already a user named "Peter" it throws an error. This field should be allowed to contain any text it wants, as it is not important. Adding a number or anything else other than a letter also throws an error.

5. The "Your Tickets" should display ALL tickets to the user. There should not be a filter applied this page. It should show all tickets.

6. Any moderator action throws an error. Changing the prefix of the ticket, changing priority, etc. As soon as an action is made, an error occurs.

7. Disabling the "priority" seems to do nothing. Even disabling all of the priority options still shows the priority box.

8. Responsive design is messy. When going to lower resolutions the sidebar is a mess and does not function as it should.

9. The password sent to the guest is on two lines for some reason. This looks very strange. The password should all be on one line.

Hope this helps.

Thanks.
 

Peter

Member
Thanks, these have been sorted now.

Hi Nix,

Unfortunately not. Here is an updated list for beta 4.


1. Ticket prefix does not update automatically.
- When a staff member replies to a ticket, the prefix should change to "Pending user reply". It does not. Likewise, when the user replies to the ticket, it should change to "Pending staff reply". Again, this does not happen.

2. When a ticket's "handling" feature is manually changed, it redirects to a page not found. Changing any field of the ticket to anything causes this issue.

3. When a guest creates a ticket, an e-mail is sent stating the ticket has been submitted. However, upon reply to that ticket by a staff member, no other e-mail is sent to the guest stating that the ticket has been replied to.

4. Password for Guest submitted tickets does not work and throws an invalid password error.

5. The "Your Tickets" should display ALL tickets to the user. There should not be a filter applied this page. It should show all tickets.

6. Any moderator action throws an error. Changing the prefix of the ticket, changing priority, etc. As soon as an action is made, an error occurs.

7. Disabling the "priority" seems to do nothing. Even disabling all of the priority options still shows the priority box.

Hope this helps.

Thanks.
 
Top