Discord Fixed Server Errors and Authentication

Nakid

Member
Hi,

I've just purchased and installed the Discord addon.

I'm getting all green ticks on the Test Discord Integration page and the bot says Hi in chat.

I'm currently on XenForo 1.5.12 and PHP Version 5.6.23.

I'm getting two issues at the moment however:
List All Roles page:
I'm not getting anything on this page besides the following error:
Server Error
Cannot use a scalar value as an array

  1. XenForo_Application::handlePhpError() in NixFifty/Discord/ControllerAdmin/Discord.php at line 322
  2. NixFifty_Discord_ControllerAdmin_Discord->actionRoles() in XenForo/FrontController.php at line 351
  3. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
  4. XenForo_FrontController->run() in <webroot>/admin.php at line 13
User Groups page:
This displays the XenForo user groups fine, but clicking on a group produces this error:

discord3.PNG
EDIT: Nevermind, this seems to have resolved itself once I gave the bot Admin rights.

I do however get this error when trying to assign a role to a user group though:
Declaration of NixFifty_TeamSpeak_DataWriter_UserGroup::_verifyServerGroupIds() should be compatible with NixFifty_Discord_DataWriter_UserGroup::_verifyServerGroupIds(&$value, XenForo_DataWriter $obj)
  1. XenForo_Application::handlePhpError() in XenForo/Autoloader.php at line 119
  2. XenForo_Autoloader::autoload() in XenForo/Autoloader.php at line 119
  3. XenForo_Autoloader->autoload() in XenForo/Application.php at line 1052
  4. XenForo_Application::autoload() in XenForo/Application.php at line 529
  5. XenForo_Application::resolveDynamicClass() in XenForo/DataWriter.php at line 2052
  6. XenForo_DataWriter::create() in NixFifty/Discord/ControllerAdmin/Discord.php at line 490
  7. NixFifty_Discord_ControllerAdmin_Discord->actionGroupsUserSave() in XenForo/FrontController.php at line 351
  8. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
  9. XenForo_FrontController->run() in <webroot>/admin.php at line 13
EDIT2: This seems to have resolved itself once I disabled your TeamSpeak addon. The data writer for each must be interfering with each other?

EDIT 3:
Issue 3: I've created a new application since it was refusing to authenticate on the original one I created when I put the callback in (same issue as from @KnoxVegas here). It now connects to the new App but won't Initiate Websocket. The button doesn't seem to do anything. I've given the bot admin rights in the server though it says offline (since no websocket is connected). Any idea? I've tried reinstalling the addon and restarting apache.
discord4.PNG
EDIT4: This seems to have resolved itself after a bit of time. It must have timed out and allowed the socket to be used again - purely speculating. I am still not able to authenticate my account. My Redirect URI is set to "https://unrealaussies.com/discord.php". When I click Associate with Discord it comes up with the correct window, asking for permissions etc. The URL I get is:
https://discordapp.com/oauth2/authorize?scope=identify email guilds&redirect_uri=https://unrealaussies.com//discord.php&response_type=code&client_id=<clientid>&state=28ff64ce

I noticed the double slash after the domain name, not sure if that has anything to do with it? I hit Authorize and it comes up with this URL:
https://discordapp.com/oauth2/error...tion=Mismatching+redirect+URI.&state=28ff64ce

And I'm presented with this screen
discord5.PNG

I tried removing a slash from the authorisation page URL: it does redirect back to my forum but I get this error:
"An error occurred while retrieving your authorization token."

Any help would be appreciated, thanks :)
 
Last edited:

Zach

Moderator
Staff member
The majority of these issues should be corrected in the next release which should come next week. Sorry for any inconvenience the delay may have caused.
 
Top